B3853:等式判断 ← 选择结构
【题目来源】
https://www.luogu.com.cn/problem/B3853
【题目描述】
给出三个整数 a,b,c,保证 b≠0。
如果a+b=c,请你输出 plus。
如果a−b=c,请你输出 minus。
如果以上两条均不满足,请输出 illegal。
【输入格式】
输入只有一行三个整数,依次表示 a,b,c。
【输出格式】
输出一行一个字符串表示答案。
【输入样例】
1 2 3
3 2 1
1 1 4
【输出样例】
plus
minus
illegal
【数据规模与约定】
对全部的测试点,保证 -2^31≤a, b, c<2^31,b≠0。
【算法代码】
#include <bits/stdc++.h>
using namespace std;
long long a,b,c;
int main() {
cin>>a>>b>>c;
if(a+b==c) cout<<"plus"<<endl;
else if(a-b==c) cout<<"minus"<<endl;
else cout<<"illegal"<<endl;
}
/*
in:
1 2 3
3 2 1
1 1 4
out:
plus
minus
illegal
*/