STL--集合:set
set的介绍
set就是数学上的集合--每个元素最多只出现一次。和sort一样,自定义类型也可以构造set,但同样必须定义“小于”运算符。set中元素具有已从小到大排好序的性质。
set的应用
题目
输入一个文本,找出所有不同的单词(连续的字母序列),按字典序从小到大输出。单词不区分大小写。
样例输入
Adventures in Disneyland Two blondes were going to Disneyland
when they came to a fork in the road. The sign read: “Disneyland
Left.” So they went home.
样例输出
a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when
代码
#include<iostream>
#include<string>
#include<set>
#include<sstream>
using namespace std;
set<string>dict;//string集合
int main(){
string s,buf;
while(cin>>s){
for(int i=0;i<s.length();i++){
if(isalpha(s[i])){//判断是否为字母
s[i]=tolower(s[i]);
}
else{
s[i]=' ';
}
}
stringstream ss(s);//字符串流处理
while(ss>>buf){//导出到buf
dict.insert(buf);
}
}
for(set<string>::iterator it=dict.begin();it!=dict.end();++it){//iterator为迭代器,类似于指针
cout<<*it<<"\n";
}
return 0;
}